Skip to main content
VulnerabilityPublished Updated

CVE-2025-37838: linux-aws-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade to 6.8.0-1042.44~22.04.1 soon.

Data as of 31 Oct 2026, 01:11 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1042.44~22.04.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu linux-aws-6.8 package to 6.8.0-1042.44~22.04.1.

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTSlinux-aws-6.8pkg:deb/ubuntu/linux-aws-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1042.44~22.04.1
Fixed in
  • 6.8.0-1042.44~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available in linux-aws-6.8.0-1042.44~22.04.1 that addresses these vulnerabilities. Users should apply this update promptly and reboot their systems to ensure all changes take effect. Due to an unavoidable ABI change, all third-party kernel modules must be recompiled and reinstalled after the update. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for AWS systems, including a flaw known as VMSCAPE that involves insufficient branch predictor isolation between a guest VM and a userspace hypervisor on certain processors. This flaw could allow an attacker in a guest VM to potentially expose sensitive information from the host OS. Additional issues affect the HSI, Bluetooth, and Timer subsystems. These vulnerabilities could be used by an attacker to compromise the system. A security update addressing these issues is available and requires a system reboot and recompilation of third-party kernel modules due to an ABI change.

References

Community reviews

Loading reviews…