CVE-2025-37756: linux-aws-6.8 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.8.0-1040.42~22.04.1 soon.
Data as of 31 Oct 2026, 01:29 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-1040.42~22.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-aws-6.8 package to 6.8.0-1040.42~22.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 22.04 LTSlinux-aws-6.8pkg:deb/ubuntu/linux-aws-6.8?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official Ubuntu security update by upgrading to linux-aws-6.8 package version 6.8.0-1040.42~22.04.1 or later. After updating, reboot the system to activate the fixes. Recompile and reinstall any third-party kernel modules due to ABI changes introduced by the update. This is the official and recommended remediation.
Description
Multiple security vulnerabilities were identified in the Linux kernel for AWS systems (linux-aws-6.8), affecting subsystems including Ext4 file system, packet sockets, network traffic control, TLS protocol, VMware vSockets driver, and XFRM subsystem. These flaws could potentially allow an attacker to compromise the system. A fixed kernel version 6.8.0-1040.42~22.04.1 has been released to address these issues. Users must update and reboot their systems to apply the fixes. Due to an ABI change, third-party kernel modules need recompilation after the update.
References
- ubuntu.com/security/notices/USN-7792-3 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37756 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37785 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38477 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38500 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38617 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38618 (opens in a new tab)