Skip to main content
CVE-2024-57996VulnerabilityPublished Updated

linux, linux-aws, linux-aws-6.8, linux-gcp, linux-lowlatency, linux-lowlatency-hwe-6.8, linux-oracle, linux-oracle-6.8

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.8.0-1036.38~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:39 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1036.38~22.04.1, 6.8.0-79.79.1~22.04.1, 6.8.0-1033.34~22.04.1 +5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-79.79
Fixed in
  • 6.8.0-79.79
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1036.38
Fixed in
  • 6.8.0-1036.38
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1037.39
Fixed in
  • 6.8.0-1037.39
Ubuntu 24.04 LTSlinux-lowlatencypkg:deb/ubuntu/linux-lowlatency?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-79.79.1
Fixed in
  • 6.8.0-79.79.1
Ubuntu 24.04 LTSlinux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1033.34
Fixed in
  • 6.8.0-1033.34
Ubuntu 22.04 LTSlinux-aws-6.8pkg:deb/ubuntu/linux-aws-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1036.38~22.04.1
Fixed in
  • 6.8.0-1036.38~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Users should update their Linux kernel packages to the fixed versions listed in the Ubuntu advisory USN-7725-1 and reboot their systems to complete the update. Due to an ABI change in the kernel, recompilation and reinstallation of any third-party kernel modules are necessary after the update. Following these steps will mitigate the vulnerabilities.

Description

Multiple security vulnerabilities were identified in the Linux kernel affecting subsystems including the Overlay file system and Network traffic control. These issues could potentially allow an attacker to compromise affected systems. Fixes have been released for various Linux kernel packages, including linux-aws-6.8 and others, primarily for Ubuntu 22.04 LTS and 24.04 LTS. Users are advised to update to the fixed versions and reboot to apply the patches. Due to an ABI change, recompilation of third-party kernel modules may be required.

References

Community reviews

Loading reviews…