Skip to main content
VulnerabilityPublished Updated

CVE-2024-52559: linux-aws-6.8, linux-gcp, linux-gcp-6.8, linux-gkeop, linux-ibm, linux-ibm-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52559· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-1035.37~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:39 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Contested

Scorers differ by 2 or more points
CVSS scores by source
CNA (Linux)CVSS 3.17.8
CISA-ADPCVSS 3.15.5
Patch
Available – fixed in 6.8.0-1035.37~22.04.1, 6.8.0-1036.38~22.04.1, 6.8.0-1033.33~22.04.1 +3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1036.38
Fixed in
  • 6.8.0-1036.38
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1019.21
Fixed in
  • 6.8.0-1019.21
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1033.33
Fixed in
  • 6.8.0-1033.33
Ubuntu 22.04 LTSlinux-aws-6.8pkg:deb/ubuntu/linux-aws-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1035.37~22.04.1
Fixed in
  • 6.8.0-1035.37~22.04.1
Ubuntu 22.04 LTSlinux-gcp-6.8pkg:deb/ubuntu/linux-gcp-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1036.38~22.04.1
Fixed in
  • 6.8.0-1036.38~22.04.1
Ubuntu 22.04 LTSlinux-ibm-6.8pkg:deb/ubuntu/linux-ibm-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1033.33~22.04.1
Fixed in
  • 6.8.0-1033.33~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel packages to the fixed versions listed in Ubuntu security notice USN-7703-2. After updating, a system reboot is required to apply the changes. Due to an ABI change, recompilation and reinstallation of all third-party kernel modules is necessary. Users should follow the vendor's update instructions carefully to ensure full remediation.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The affected subsystems include various hardware architectures (ARM64, PowerPC, x86), device drivers, networking components, filesystems, and kernel subsystems such as memory management and process accounting. The vulnerabilities are addressed in updated Linux kernel packages for several cloud and enterprise platforms including AWS, GCP, IBM, and Ubuntu LTS releases. Users are advised to apply the available patches and reboot to ensure the fixes take effect.

References

Community reviews

Loading reviews…