Skip to main content
VulnerabilityPublished Updated

CVE-2025-71289: linux-aws-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-71289· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 6.8.0-1064.67+fips1 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Linux)CVSS 3.17.1
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1064.67+fips1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu linux-aws-fips package to 6.8.0-1064.67+fips1.

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 24.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1064.67+fips1
Fixed in
  • 6.8.0-1064.67+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update by upgrading to linux-aws-fips package version 6.8.0-1064.67+fips1 or later as provided by Ubuntu's security notice USN-8729-5. After updating, reboot the system to activate the fixes. Due to an ABI change, recompile and reinstall all third-party kernel modules to ensure compatibility with the updated kernel. No additional mitigation steps are indicated by the vendor advisory.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for AWS FIPS systems affecting numerous subsystems including architectures (ARM32, ARM64, PowerPC), drivers, networking, filesystems, and security modules. These flaws could potentially allow an attacker to compromise the system. A security update addressing these issues is available and requires a system reboot and recompilation of third-party kernel modules due to ABI changes.

References

Community reviews

Loading reviews…