Skip to main content
VulnerabilityPublished Updated

CVE-2026-23060: linux-fips, linux-aws-fips, linux-gcp-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-23060· High

Not known to be exploited · fixed in 6.8.0-1051.54+fips1 : patch Linux kernel soon.

Data as of 5 Nov 2026, 00:01 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1051.54+fips1, 6.8.0-107.107+fips1, 6.8.0-1053.56+fips1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1051.54+fips1 (linux-aws-fips package) or 6.8.0-107.107+fips1 (linux-fips package) or 6.8.0-1053.56+fips1 (linux-gcp-fips package).

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 24.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1051.54+fips1
Fixed in
  • 6.8.0-1051.54+fips1
Ubuntu Pro FIPS-updates 24.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-107.107+fips1
Fixed in
  • 6.8.0-107.107+fips1
Ubuntu Pro FIPS-updates 24.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1053.56+fips1
Fixed in
  • 6.8.0-1053.56+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating to the fixed package versions: 6.8.0-1051.54+fips1, 6.8.0-107.107+fips1, or 6.8.0-1053.56+fips1 depending on the platform. After updating, a system reboot is required to activate the fixes. Due to ABI changes, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory instructions for updating and recompilation.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting the Cryptographic API, Netfilter, and Network traffic control subsystems. These flaws could potentially allow an attacker to compromise the system. Fixes have been released in updated Linux kernel packages for various FIPS-certified builds, including linux-aws-fips, linux-gcp-fips, and linux-fips. Users are advised to update and reboot their systems to apply the patches. Due to ABI changes, recompilation of third-party kernel modules may be necessary.

References

Community reviews

Loading reviews…