Skip to main content
VulnerabilityPublished Updated

CVE-2025-37849: linux-fips, linux-aws-fips, linux-gcp-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 5.15.0-1104.111+fips1 : patch Linux kernel soon.

Data as of 5 Nov 2026, 00:01 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1104.111+fips1, 5.15.0-174.184+fips1, 5.15.0-1104.113+fips1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu to 5.15.0-1104.111+fips1 (linux-aws-fips package) or 5.15.0-174.184+fips1 (linux-fips package) or 5.15.0-1104.113+fips1 (linux-gcp-fips package).

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 22.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-1104.111+fips1
Fixed in
  • 5.15.0-1104.111+fips1
Ubuntu Pro FIPS-updates 22.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-174.184+fips1
Fixed in
  • 5.15.0-174.184+fips1
Ubuntu Pro FIPS-updates 22.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-1104.113+fips1
Fixed in
  • 5.15.0-1104.113+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly by updating to the fixed kernel versions 5.15.0-1104.111+fips1, 5.15.0-174.184+fips1, or 5.15.0-1104.113+fips1 as appropriate. After updating, a system reboot is required to activate the fixes. Due to an ABI change in the kernel, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor's update instructions carefully to ensure full remediation.

Description

Multiple security vulnerabilities were identified in the Linux kernel affecting ARM64 architecture, Cryptographic API, Netfilter, and network traffic control subsystems. These flaws could potentially allow an attacker to compromise the system. The issues affect various linux-fips kernel variants including linux-aws-fips and linux-gcp-fips. Fixes have been released in updated kernel versions, and a system reboot is required after applying the updates. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled after the update.

References

Community reviews

Loading reviews…