Skip to main content
VulnerabilityPublished Updated

CVE-2024-36347: linux-aws, linux-aws-6.17, linux-hwe-6.17, linux-oracle, linux-oracle-6.17 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2024-36347· Medium 6.4

Not known to be exploited · CVSS 6.4 Medium · fixed in 6.17.0-1012.12~24.04.1 : update Linux kernel when convenient.

Data as of 3 Nov 2026, 17:28 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.17.0-1012.12~24.04.1, 6.17.0-22.22~24.04.1, 6.17.0-1011.11~24.04.1 +2
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1011.11
Fixed in
  • 6.17.0-1011.11
Ubuntu 24.04 LTSlinux-aws-6.17pkg:deb/ubuntu/linux-aws-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-1012.12~24.04.1
Fixed in
  • 6.17.0-1012.12~24.04.1
Ubuntu 24.04 LTSlinux-hwe-6.17pkg:deb/ubuntu/linux-hwe-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-22.22~24.04.1
Fixed in
  • 6.17.0-22.22~24.04.1
Ubuntu 24.04 LTSlinux-oracle-6.17pkg:deb/ubuntu/linux-oracle-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-1011.11~24.04.1
Fixed in
  • 6.17.0-1011.11~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released by Ubuntu for the affected kernel packages. Users should update their systems to the fixed versions listed in the advisory (e.g., 6.17.0-1012.12~24.04.1, 6.17.0-22.22~24.04.1, 6.17.0-1011.11~24.04.1, 6.17.0-1012.12, 6.17.0-1011.11) and reboot to apply the changes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Following the vendor's update instructions will mitigate these vulnerabilities.

Description

A vulnerability identified as EntrySign (CVE-2024-36347) affects some AMD Zen processors where CPU microcode signature verification is improperly performed. This flaw allows a privileged attacker to potentially load malicious CPU microcode, leading to loss of system integrity and confidentiality. Additionally, multiple other security issues were found and fixed in various Linux kernel subsystems. Updates addressing these vulnerabilities are available for linux-aws, linux-aws-6.17, linux-hwe-6.17, linux-oracle, and linux-oracle-6.17 kernels.

References

Community reviews

Loading reviews…