Skip to main content
VulnerabilityPublished Updated

CVE-2025-10263: linux-aws, linux-aws-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-10263· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 6.8.0-1065.68~22.04.1 : patch Linux kernel as a priority.

Data as of 6 Nov 2026, 14:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.0-1065.68~22.04.1, 6.8.0-1065.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1065.68~22.04.1 (linux-aws-6.8 package) or 6.8.0-1065.68 (linux-aws package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1065.68
Fixed in
  • 6.8.0-1065.68
Ubuntu 22.04 LTSlinux-aws-6.8pkg:deb/ubuntu/linux-aws-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1065.68~22.04.1
Fixed in
  • 6.8.0-1065.68~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately by updating to linux-aws-6.8 kernel versions 6.8.0-1065.68 or 6.8.0-1065.68~22.04.1 as appropriate for your Ubuntu release. After updating, a system reboot is required to activate the fixes. Due to an unavoidable ABI change, all third-party kernel modules must be recompiled and reinstalled. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for AWS systems, including a critical issue affecting some ARM processors. This ARM64 flaw allows a local attacker to write to memory after permissions were revoked by exploiting a timing issue with the translation lookaside buffer (TLB) invalidation. Additional vulnerabilities affect various kernel subsystems such as InfiniBand, network drivers, and multiple networking protocols. These issues could potentially allow attackers to bypass memory protections or escalate privileges. Fixes have been released and are available in updated linux-aws-6.8 kernel packages. A system reboot is required after applying updates, and third-party kernel modules may need recompilation due to ABI changes.

References

Community reviews

Loading reviews…