Skip to main content
VulnerabilityPublished Updated

CVE-2025-71289: linux-gcp-6.8, linux-ibm, linux-xilinx vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-71289· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 6.8.0-1067.75~22.04.1 : patch Linux kernel soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Linux)CVSS 3.17.1
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1067.75~22.04.1, 6.8.0-1064.65, 6.8.0-1036.37
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1067.75~22.04.1 (linux-gcp-6.8 package) or 6.8.0-1064.65 (linux-ibm package) or 6.8.0-1036.37 (linux-xilinx package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1064.65
Fixed in
  • 6.8.0-1064.65
Ubuntu 24.04 LTSlinux-xilinxpkg:deb/ubuntu/linux-xilinx?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1036.37
Fixed in
  • 6.8.0-1036.37
Ubuntu 22.04 LTSlinux-gcp-6.8pkg:deb/ubuntu/linux-gcp-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1067.75~22.04.1
Fixed in
  • 6.8.0-1067.75~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Ubuntu has released updated kernel packages for linux-gcp-6.8, linux-ibm, and linux-xilinx addressing these vulnerabilities. After updating, a system reboot is required to apply the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Users should follow the official Ubuntu security notice USN-8729-3 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems including various architectures, drivers, networking components, filesystems, and security modules. These flaws could potentially allow an attacker to compromise the affected system. Updates correcting these issues have been released for several Linux kernel variants including linux-gcp-6.8, linux-ibm, and linux-xilinx.

References

Community reviews

Loading reviews…