Skip to main content
CVE-2024-52559VulnerabilityPublished Updated

linux-gke, linux-hwe-6.8, linux-nvidia, linux-nvidia-6.8, linux-nvidia-lowlatency, linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52559· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-78.78~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:39 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Contested

Scorers differ by 2 or more points
CVSS scores by source
CNA (Linux)CVSS 3.17.8
CISA-ADPCVSS 3.15.5
Patch
Available – fixed in 6.8.0-78.78~22.04.1, 6.8.0-1035.38~22.04.1, 6.8.0-1032.36 +3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1032.36
Fixed in
  • 6.8.0-1032.36
Ubuntu 24.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1035.38
Fixed in
  • 6.8.0-1035.38
Ubuntu 24.04 LTSlinux-nvidia-lowlatencypkg:deb/ubuntu/linux-nvidia-lowlatency?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1035.38.1
Fixed in
  • 6.8.0-1035.38.1
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1035.39
Fixed in
  • 6.8.0-1035.39
Ubuntu 22.04 LTSlinux-hwe-6.8pkg:deb/ubuntu/linux-hwe-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-78.78~22.04.1
Fixed in
  • 6.8.0-78.78~22.04.1
Ubuntu 22.04 LTSlinux-nvidia-6.8pkg:deb/ubuntu/linux-nvidia-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1035.38~22.04.1
Fixed in
  • 6.8.0-1035.38~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel packages to the fixed versions listed by Ubuntu (e.g., 6.8.0-78.78~22.04.1, 6.8.0-1035.38~22.04.1, etc.) and reboot the system to apply the updates. Due to an ABI change, recompilation and reinstallation of all third-party kernel modules are necessary after updating. Follow the Ubuntu security notice USN-7703-4 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The affected components include various hardware architectures, drivers, network protocols, filesystems, and kernel subsystems. Ubuntu has released updates correcting these flaws in several kernel packages for different Ubuntu releases. Users are advised to update and reboot to apply the fixes.

References

Community reviews

Loading reviews…