CVE-2024-58090: linux-hwe-6.8 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.8.0-85.85~22.04.1 soon.
Data as of 31 Oct 2026, 01:29 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-85.85~22.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-hwe-6.8 package to 6.8.0-85.85~22.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 22.04 LTSlinux-hwe-6.8pkg:deb/ubuntu/linux-hwe-6.8?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied immediately by upgrading to linux-hwe-6.8 version 6.8.0-85.85~22.04.1 or later. After updating, a system reboot is required to activate the fixes. Due to an ABI change in the kernel update, all third-party kernel modules must be recompiled and reinstalled to ensure compatibility. Follow the official Ubuntu security notice USN-7801-1 for detailed upgrade instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems including architectures (ARM32, ARM64, x86), device drivers, filesystems, networking protocols, and kernel infrastructure. These flaws could potentially allow an attacker to compromise the system. A security update correcting these issues is available for the linux-hwe-6.8 kernel package on Ubuntu 22.04 LTS.
References
- ubuntu.com/security/notices/USN-7801-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58090 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21872 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21873 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21875 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21877 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21878 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21880 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21881 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21883 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21885 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21888 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21889 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21890 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21891 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21892 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21894 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21895 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21898 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21899 (opens in a new tab)