Skip to main content
CVE-2025-38083VulnerabilityPublished Updated

linux, linux-aws, linux-aws-6.14, linux-gcp, linux-gcp-6.14, linux-hwe-6.14, linux-oem-6.14, linux-raspi

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.14.0-1010.10~24.04.1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 18:14 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.14.0-1010.10~24.04.1, 6.14.0-1012.12~24.04.1, 6.14.0-27.27~24.04.1 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1010.10~24.04.1
Fixed in
  • 6.14.0-1010.10~24.04.1
Ubuntu 24.04 LTSlinux-gcp-6.14pkg:deb/ubuntu/linux-gcp-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1012.12~24.04.1
Fixed in
  • 6.14.0-1012.12~24.04.1
Ubuntu 24.04 LTSlinux-hwe-6.14pkg:deb/ubuntu/linux-hwe-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-27.27~24.04.1
Fixed in
  • 6.14.0-27.27~24.04.1
Ubuntu 24.04 LTSlinux-oem-6.14pkg:deb/ubuntu/linux-oem-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1008.8
Fixed in
  • 6.14.0-1008.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating the Linux kernel packages to the fixed versions listed by Ubuntu. After updating, a system reboot is required to activate the fixes. Due to an ABI change in the kernel update, all third-party kernel modules must be recompiled and reinstalled. Users should follow the official Ubuntu security notice USN-7681-1 for detailed update instructions.

Description

Multiple security vulnerabilities were identified in the Linux kernel affecting network traffic control subsystems. These flaws could potentially allow an attacker to compromise the system. The issues have been addressed in updated Linux kernel packages for various Ubuntu releases and platforms including AWS, GCP, OEM, Raspberry Pi, and others. Users must apply the updates and reboot to ensure protection. Due to ABI changes, recompilation of third-party kernel modules is required after updating.

References

Community reviews

Loading reviews…