Skip to main content
CVE-2025-38350VulnerabilityPublished Updated

linux, linux-aws, linux-aws-6.14, linux-gcp, linux-hwe-6.14, linux-raspi, linux-realtime, linux-realtime-6.14

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.14.0-1012.12~24.04.1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:28 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.14.0-1012.12~24.04.1, 6.14.0-29.29~24.04.1, 6.14.0-1011.11~24.04.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.14.0-1012.12~24.04.1 (linux-aws-6.14 package) or 6.14.0-29.29~24.04.1 (linux-hwe-6.14 package) or 6.14.0-1011.11~24.04.1 (linux-realtime-6.14 package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1012.12~24.04.1
Fixed in
  • 6.14.0-1012.12~24.04.1
Ubuntu 24.04 LTSlinux-hwe-6.14pkg:deb/ubuntu/linux-hwe-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-29.29~24.04.1
Fixed in
  • 6.14.0-29.29~24.04.1
Ubuntu Pro Realtime 24.04 LTSlinux-realtime-6.14pkg:deb/ubuntu/linux-realtime-6.14?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.14.0-1011.11~24.04.1
Fixed in
  • 6.14.0-1011.11~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel packages to the fixed versions listed in the Ubuntu advisory USN-7722-1. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled to ensure compatibility with the updated kernel. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

A security vulnerability was discovered in the Linux kernel affecting the network traffic control subsystem. This flaw could potentially allow an attacker to compromise the system. The issue affects multiple Linux kernel variants including linux-aws, linux-gcp, linux-hwe, linux-raspi, and linux-realtime. Fixes have been released and are available in updated kernel versions. Users are advised to update and reboot their systems to apply the patches. Due to an ABI change, recompilation of third-party kernel modules may be required after the update.

References

Community reviews

Loading reviews…