linux, linux-aws, linux-aws-6.14, linux-gcp, linux-gcp-6.14, linux-oracle, linux-oracle-6.14, linux-raspi
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.14.0-1011.11~24.04.1 : patch Linux kernel soon.
Data as of 3 Nov 2026, 18:14 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.14.0-1011.11~24.04.1, 6.14.0-1014.15~24.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 18 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu to 6.14.0-1011.11~24.04.1 (linux-aws-6.14 package, linux-oracle-6.14 package) or 6.14.0-1014.15~24.04.1 (linux-gcp-6.14 package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcp-6.14pkg:deb/ubuntu/linux-gcp-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-oracle-6.14pkg:deb/ubuntu/linux-oracle-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update their Linux kernel packages to versions 6.14.0-1011.11~24.04.1 or 6.14.0-1014.15~24.04.1 or later as provided by Ubuntu security notices (USN-7699-1). After updating, a system reboot is required to apply the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled to maintain compatibility. Follow the vendor advisory instructions carefully to ensure complete remediation.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems and architectures. These flaws could potentially allow an attacker to compromise the system. The issues impact a wide range of components including ARM64, RISC-V, x86 architectures, various drivers, file systems, networking components, and kernel infrastructure. Ubuntu has released patches addressing these vulnerabilities in specific kernel versions. Users should update to the fixed versions and reboot to apply the changes. Due to an ABI change, recompilation of third-party kernel modules may be required.
References
- ubuntu.com/security/notices/USN-7699-1 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37947 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37948 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37949 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37950 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37951 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37952 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37954 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37955 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37956 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37957 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37958 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37959 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37960 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37961 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37962 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37963 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37964 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37965 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37966 (opens in a new tab)