Skip to main content
VulnerabilityPublished Updated

CVE-2025-38477: linux, linux-aws, linux-aws-6.14, linux-hwe-6.14, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.14.0-1014.14~24.04.1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:29 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.14.0-1014.14~24.04.1, 6.14.0-33.33~24.04.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.14.0-1014.14~24.04.1 (linux-aws-6.14 package) or 6.14.0-33.33~24.04.1 (linux-hwe-6.14 package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1014.14~24.04.1
Fixed in
  • 6.14.0-1014.14~24.04.1
Ubuntu 24.04 LTSlinux-hwe-6.14pkg:deb/ubuntu/linux-hwe-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-33.33~24.04.1
Fixed in
  • 6.14.0-33.33~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly by updating to the fixed kernel versions 6.14.0-1014.14~24.04.1 or 6.14.0-33.33~24.04.1 as appropriate. After updating, a system reboot is required to activate the new kernel. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled to maintain compatibility. Follow the vendor's update instructions carefully.

Description

Multiple security vulnerabilities were identified in the Linux kernel affecting subsystems including packet sockets, network traffic control, VMware vSockets driver, and the XFRM subsystem. These flaws could potentially allow an attacker to compromise the affected system. Fixes have been released for the linux-aws-6.14 and related kernel packages, requiring system updates and a reboot. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled after updating.

References

Community reviews

Loading reviews…