Skip to main content
VulnerabilityPublished Updated

CVE-2025-40025: linux, linux-aws, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.17.0-7.7 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:44 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.17.0-7.7, 6.17.0-1004.4, 6.17.0-1003.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.17.0-7.7 (linux package) or 6.17.0-1004.4 (linux-aws package) or 6.17.0-1003.4 (linux-realtime package).

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-7.7
Fixed in
  • 6.17.0-7.7
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1004.4
Fixed in
  • 6.17.0-1004.4
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1003.4
Fixed in
  • 6.17.0-1003.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating to Linux kernel versions 6.17.0-7.7, 6.17.0-1004.4, or 6.17.0-1003.4 as appropriate for the system. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory instructions at https://ubuntu.com/security/notices/USN-7906-1 for detailed update guidance.

Description

Multiple security vulnerabilities were identified in the Linux kernel affecting various subsystems including x86 architecture, Cryptographic API, Android drivers, TTY drivers, F2FS file system, and 9P file system network protocol. These flaws could potentially allow an attacker to compromise the system. The issues have been addressed in updated Linux kernel versions, and users are advised to apply these updates and reboot their systems. Due to an ABI change, recompilation and reinstallation of third-party kernel modules are required after updating.

References

Community reviews

Loading reviews…