Skip to main content
VulnerabilityPublished Updated

CVE-2025-40001: linux, linux-raspi, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.17.0-14.14 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:31 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.17.0-14.14, 6.17.0-1008.8, 6.17.0-1006.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.17.0-14.14 (linux package) or 6.17.0-1008.8 (linux-raspi package) or 6.17.0-1006.7 (linux-realtime package).

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-14.14
Fixed in
  • 6.17.0-14.14
Ubuntu 25.10linux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.8
Fixed in
  • 6.17.0-1008.8
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1006.7
Fixed in
  • 6.17.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Users should update their Linux kernel to the fixed versions 6.17.0-14.14, 6.17.0-1008.8, or 6.17.0-1006.7 as appropriate for their distribution. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled to ensure compatibility. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8029-1 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The vulnerabilities impact numerous kernel components including architectures such as ARM64, x86, RISC-V, and drivers, filesystems, networking, and more. A patch has been released to address these flaws, and users are advised to update to the fixed kernel versions and reboot their systems.

References

Community reviews

Loading reviews…