CVE-2024-36347: linux, linux-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 6.4 Medium · fixed in 6.17.0-22.22 : update Linux kernel when convenient.
Data as of 3 Nov 2026, 17:32 UTC
- Patch
- Available – fixed in 6.17.0-22.22, 6.17.0-1010.11
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu to 6.17.0-22.22 (linux package) or 6.17.0-1010.11 (linux-realtime package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Users should update their Linux kernel to versions 6.17.0-22.22 or 6.17.0-1010.11 or later as provided by their distribution vendor. After updating, a system reboot is required to apply the fixes. Due to ABI changes, third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8177-1 for detailed update instructions.
Description
A set of vulnerabilities affecting the Linux kernel and Linux-realtime kernel have been identified, including a critical flaw named EntrySign in AMD Zen processors where CPU microcode signature verification is improper. This flaw could allow a privileged attacker to load malicious CPU microcode, potentially compromising system integrity and confidentiality. Numerous other security issues across various kernel subsystems and drivers have also been fixed in this update.
References
- ubuntu.com/security/notices/USN-8177-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-36347 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68351 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68353 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68365 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68368 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68725 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68745 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68767 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68768 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68769 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68770 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68771 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68772 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68773 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68774 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68775 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68776 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68777 (opens in a new tab)