Skip to main content
VulnerabilityPublished Updated

CVE-2025-40018: linux, linux-aws, linux-gcp, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.17.0-8.8 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:31 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.17.0-8.8, 6.17.0-1005.5, 6.17.0-1004.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.17.0-8.8 (linux package) or 6.17.0-1005.5 (linux-aws package, linux-gcp package) or 6.17.0-1004.5 (linux-realtime package).

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-8.8
Fixed in
  • 6.17.0-8.8
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1005.5
Fixed in
  • 6.17.0-1005.5
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1005.5
Fixed in
  • 6.17.0-1005.5
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1004.5
Fixed in
  • 6.17.0-1004.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel to versions 6.17.0-8.8, 6.17.0-1005.5, or 6.17.0-1004.5 as appropriate for their environment. After updating, a system reboot is required to apply the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting the tracing infrastructure and Netfilter subsystems. These flaws could potentially allow an attacker to compromise the system. The issues have been addressed in updated Linux kernel versions, and users are advised to apply the updates and reboot their systems. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary.

References

Community reviews

Loading reviews…