Skip to main content
VulnerabilityPublished Updated

CVE-2025-54518: linux, linux-gcp, linux-gke, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54518· High 7.3

Not known to be exploited · CVSS 7.3 High · fixed in 7.0.0-28.28 : patch Linux kernel soon.

Data as of 6 Nov 2026, 15:03 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.0.0-28.28, 7.0.0-1008.8, 7.0.0-1003.4 +1
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-28.28
Fixed in
  • 7.0.0-28.28
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1003.4
Fixed in
  • 7.0.0-1003.4
Ubuntu 26.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-28.28.1
Fixed in
  • 7.0.0-28.28.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel to the fixed versions listed (e.g., 7.0.0-28.28, 7.0.0-1008.8, 7.0.0-1003.4, 7.0.0-28.28.1) as provided by their distribution vendor, such as Ubuntu's USN-8566-1 advisory. After updating, a system reboot is required to apply the fixes. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. No other immediate actions are required beyond applying the official updates.

Description

Multiple security vulnerabilities were discovered in the Linux kernel, including a critical issue affecting AMD Zen 2 processors where improper isolation of shared resources in the operation cache could allow a local attacker to corrupt instructions executed at a higher privilege level, leading to privilege escalation. The update addresses numerous flaws across a wide range of kernel subsystems and architectures. Users are advised to update to the fixed kernel versions and reboot to apply the patches.

References

Community reviews

Loading reviews…