Skip to main content
VulnerabilityPublished Updated

CVE-2024-52559: linux-oracle, linux-oracle-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52559· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-1032.33~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:39 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Contested

Scorers differ by 2 or more points
CVSS scores by source
CNA (Linux)CVSS 3.17.8
CISA-ADPCVSS 3.15.5
Patch
Available – fixed in 6.8.0-1032.33~22.04.1, 6.8.0-1032.33
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1032.33~22.04.1 (linux-oracle-6.8 package) or 6.8.0-1032.33 (linux-oracle package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1032.33
Fixed in
  • 6.8.0-1032.33
Ubuntu 22.04 LTSlinux-oracle-6.8pkg:deb/ubuntu/linux-oracle-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1032.33~22.04.1
Fixed in
  • 6.8.0-1032.33~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately by updating to linux-oracle-6.8 kernel versions 6.8.0-1032.33 or 6.8.0-1032.33~22.04.1 as appropriate for your Ubuntu release. After updating, a system reboot is required to activate the fixes. Note that due to an ABI change, all third-party kernel modules must be recompiled and reinstalled to ensure compatibility. Follow the vendor's update instructions carefully to fully remediate the vulnerabilities.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The vulnerabilities impact a wide range of components including CPU architectures (ARM64, PowerPC, x86), various device drivers, network protocols, filesystems, and kernel subsystems. A patch addressing these vulnerabilities is available and included in updated linux-oracle-6.8 kernel packages.

References

Community reviews

Loading reviews…