CVE-2024-52559: linux-raspi-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 6.8.0-2028.29 soon.
Data as of 31 Oct 2026, 01:39 UTC
Contested
Scorers differ by 2 or more points| CNA (Linux) | CVSS 3.1 | 7.8 |
|---|---|---|
| CISA-ADP | CVSS 3.1 | 5.5 |
- Patch
- Available – fixed in 6.8.0-2028.29
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-raspi-realtime package to 6.8.0-2028.29.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to Linux kernel version 6.8.0-2028.29 or later. After updating, a system reboot is required to apply the fixes. Due to an ABI change in the kernel update, all third-party kernel modules must be recompiled and reinstalled. Users should follow the official Ubuntu security notice USN-7719-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi Real-time systems affecting numerous subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The vulnerabilities impact a wide range of kernel components including architectures (ARM64, PowerPC, x86), device drivers, networking protocols, filesystems, and kernel subsystems. A patch addressing these vulnerabilities is available in version 6.8.0-2028.29.
References
- ubuntu.com/security/notices/USN-7719-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-52559 (opens in a new tab)
- ubuntu.com/security/CVE-2024-54456 (opens in a new tab)
- ubuntu.com/security/CVE-2024-54458 (opens in a new tab)
- ubuntu.com/security/CVE-2024-57834 (opens in a new tab)
- ubuntu.com/security/CVE-2024-57977 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58020 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58086 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58088 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58093 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21704 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21706 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21712 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21746 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21758 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21759 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21760 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21761 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21762 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21763 (opens in a new tab)