CVE-2024-58090: linux-raspi-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.8.0-2031.32 soon.
Data as of 31 Oct 2026, 01:29 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-2031.32
Exploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-raspi-realtime package to 6.8.0-2031.32.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update to Linux kernel version 6.8.0-2031.32 or later. After updating, a system reboot is required to apply all changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-7800-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi Real-time systems affecting numerous subsystems and drivers. These issues could potentially allow an attacker to compromise the system. The vulnerabilities have been addressed in an updated kernel version 6.8.0-2031.32. Users are advised to apply the update and reboot to ensure all fixes take effect. Due to an ABI change, recompilation and reinstallation of third-party kernel modules are required after updating.
References
- ubuntu.com/security/notices/USN-7800-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58090 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21872 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21873 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21875 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21877 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21878 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21880 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21881 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21883 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21885 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21888 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21889 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21890 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21891 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21892 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21894 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21895 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21898 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21899 (opens in a new tab)