CVE-2024-57996: linux-realtime, linux-raspi-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.8.0-2029.30 : patch Linux kernel soon.
Data as of 31 Oct 2026, 01:39 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-2029.30, 6.8.1-1031.32
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu to 6.8.0-2029.30 (linux-raspi-realtime package) or 6.8.1-1031.32 (linux-realtime package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro Realtime 24.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly by updating to linux-raspi-realtime kernel versions 6.8.0-2029.30 or 6.8.1-1031.32 as provided by Ubuntu security updates. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Users should follow the official Ubuntu advisory instructions at https://ubuntu.com/security/notices/USN-7725-2 for detailed update procedures.
Description
Multiple security vulnerabilities were identified in the Linux kernel, specifically affecting the Overlay file system and Network traffic control subsystems. These flaws could potentially allow an attacker to compromise affected systems. The vulnerabilities impact the linux-raspi-realtime kernel versions prior to 6.8.0-2029.30 and 6.8.1-1031.32, as well as several specific 6.7.0 and 6.8.0 builds. A patch has been released and is available through Ubuntu security updates. Users must reboot after updating and recompile any third-party kernel modules due to an ABI change.