CVE-2024-36347: linux-raspi-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 6.4 Medium : upgrade to 6.8.0-2042.43 when convenient.
Data as of 31 Oct 2026, 01:10 UTC
- Patch
- Available – fixed in 6.8.0-2042.43
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-raspi-realtime package to 6.8.0-2042.43.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by updating to linux-raspi-realtime kernel version 6.8.0-2042.43 or later. After updating, a system reboot is required to apply changes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Users should follow the official Ubuntu security notice USN-8204-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi Real-time systems, including a critical flaw (CVE-2024-36347) affecting AMD Zen processors where CPU microcode signature verification is improper. This flaw, known as EntrySign, allows a privileged attacker to load malicious CPU microcode, potentially causing loss of system integrity and confidentiality. Numerous other kernel subsystems and drivers were also affected by various security issues. A patch is available to address these vulnerabilities.
References
- ubuntu.com/security/notices/USN-8204-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-36347 (opens in a new tab)
- ubuntu.com/security/CVE-2024-57795 (opens in a new tab)
- ubuntu.com/security/CVE-2025-22022 (opens in a new tab)
- ubuntu.com/security/CVE-2025-22111 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38022 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38234 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40164 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40325 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68206 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68254 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68255 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68256 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68257 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68258 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68259 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68261 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68263 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68264 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68265 (opens in a new tab)