CVE-2024-36347: linux-realtime-6.17 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 6.4 Medium : upgrade to 6.17.0-1010.11~24.04.1 when convenient.
Data as of 3 Nov 2026, 17:29 UTC
- Patch
- Available – fixed in 6.17.0-1010.11~24.04.1
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu linux-realtime-6.17 package to 6.17.0-1010.11~24.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-realtime-6.17pkg:deb/ubuntu/linux-realtime-6.17?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Update the linux-realtime-6.17 kernel package to version 6.17.0-1010.11~24.04.1 or later as provided by the Ubuntu security advisory USN-8177-2. After updating, reboot the system to apply changes. Note that due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Applying this update addresses the EntrySign vulnerability and numerous other kernel security issues.
Description
Multiple security vulnerabilities were discovered in the Linux kernel version linux-realtime-6.17, including a critical flaw (CVE-2024-36347) affecting AMD Zen processors where CPU microcode signature verification is improper. This flaw, known as EntrySign, could allow a privileged attacker to load malicious CPU microcode, leading to loss of system integrity and confidentiality. Numerous other vulnerabilities affect a wide range of kernel subsystems and drivers. These issues have been addressed in the updated package version 6.17.0-1010.11~24.04.1.
References
- ubuntu.com/security/notices/USN-8177-2 (opens in a new tab)
- ubuntu.com/security/CVE-2024-36347 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68351 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68353 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68365 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68368 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68725 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68745 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68767 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68768 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68769 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68770 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68771 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68772 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68773 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68774 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68775 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68776 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68777 (opens in a new tab)