Skip to main content
VulnerabilityPublished Updated

CVE-2026-63188: logto-tunnel serves files outside `--experience-path` via path traversal

Affects @logto/tunnelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-63188· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 0.3.9 soon.

Data as of 5 Nov 2026, 18:50 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.3.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade @logto/tunnel to 0.3.9.

Affected software

ProductAffectedFixed in
npm@logto/tunnelAffected
  • <0.3.9
Fixed in
  • 0.3.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in version 0.3.9 of @logto/tunnel. Users should upgrade to version 0.3.9 or later to remediate this vulnerability. Until upgraded, restricting network access to the tunnel port can reduce exposure. No other vendor advisory mitigation instructions are provided.

Description

The @logto/tunnel CLI tool has a path traversal vulnerability (CVE-2026-63188) that allows an unauthenticated remote attacker to read arbitrary files outside the configured custom sign-in experience directory. This occurs because the tunnel serves static files from a specified directory but does not properly validate or normalize request paths, allowing '../' sequences to escape the intended directory. The vulnerability affects versions prior to 0.3.9 and has a high severity CVSS score of 8.7.

References

Community reviews

Loading reviews…