Skip to main content
VulnerabilityPublished Updated

CVE-2026-22813: Malicious website can execute commands on the local system through XSS in the OpenCode web UI

Affects opencodeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-22813· Critical 9.4

Not known to be exploited · CVSS 9.4 Critical : upgrade to 1.1.10 as a priority.

Data as of 30 Oct 2026, 05:15 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.1.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade opencode to 1.1.10.

Affected software

ProductAffectedFixed in
Homebrewopencodepkg:brew/opencodeOther threatsAffected
  • <1.1.10
Fixed in
  • 1.1.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

OpenCode is an open source AI coding agent. The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via HTML injection. This means controlling the LLM response for a chat session gets JavaScript execution on the http://localhost:4096 origin. This vulnerability is fixed in 1.1.10.

References

Community reviews

Loading reviews…