Skip to main content
VulnerabilityPublished Updated

CVE-2026-22812: OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution

Affects opencodeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-22812· High 8.8

Not known to be exploited · public detection template (Nuclei) · CVSS 8.8 High : upgrade to 1.0.217 soon.

Data as of 30 Oct 2026, 05:15 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.0.217
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade opencode to 1.0.217.

Affected software

ProductAffectedFixed in
Homebrewopencodepkg:brew/opencodeOther threatsAffected
  • <1.0.217
Fixed in
  • 1.0.217

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

OpenCode is an open source AI coding agent. Prior to 1.0.216, OpenCode automatically starts an unauthenticated HTTP server that allows any local process (or any website via permissive CORS) to execute arbitrary shell commands with the user's privileges. This vulnerability is fixed in 1.0.216.

References

Community reviews

Loading reviews…