CVE-2026-55448: Mise's local credential_command executes untrusted config
Affects miseSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2026.6.4 when convenient.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.6.4
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade mise to 2026.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| crates.iomise | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in mise version 2026.6.4 that disables honoring 'github.credential_command' from non-global project configuration files. Users should upgrade to version 2026.6.4 or later to remediate this vulnerability. Until patched, avoid running mise commands in untrusted repositories or ensure that higher-priority GitHub token environment variables are set to prevent the vulnerable code path from being executed.
Description
The 'mise' tool versions from 2026.3.15 up to but not including 2026.6.4 allow local project configuration files (.mise.toml) to specify a 'github.credential_command' that is executed without trust validation. This enables an attacker who can place a malicious .mise.toml in a repository to execute arbitrary shell commands as the victim user when the victim runs a GitHub-related mise command and no higher-priority GitHub token environment variable is set. The vulnerability is fixed in version 2026.6.4.