MRBS (Meeting Room Booking System) before 1.12.3 contains a reflected cross-site scripting vulnerability that allows
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.12.3 when convenient.
Data as of 8 Nov 2026, 17:51 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.1 |
- Patch
- Available – fixed in 1.12.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade mrbs-code to 1.12.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| meeting-room-booking-systemmrbs-code | Affected
| Fixed in
|
GitHubmrbs-codepkg:github/mrbs-codeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 1.12.3 or later should be applied to remediate this vulnerability. Since the input data does not provide explicit patch links or vendor advisory, users should upgrade to MRBS version 1.12.3 or later as this version addresses the reflected XSS issue. Until patched, avoid clicking on untrusted links that reference the view_entry.php error parameter.
Description
MRBS (Meeting Room Booking System) versions before 1.12.3 have a reflected cross-site scripting (XSS) vulnerability in the view_entry.php script via the error parameter. This flaw allows unauthenticated attackers to craft malicious links that, when visited by logged-in users, can execute scripts to read CSRF tokens and perform unauthorized actions such as modifying or deleting bookings or executing administrative functions.
References
- github.com/meeting-room-booking-system/mrbs-code/security/advisories/GHSA-5wqw-q7gh-j65v (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-124474 (opens in a new tab)
- github.com/meeting-room-booking-system/mrbs-code/commit/83b8253853359964f850208c28036b2bfa202466 (opens in a new tab)
- github.com/meeting-room-booking-system/mrbs-code/blob/38d51e05f4a0ab39820f3830ca5dcae5f34d8546/web/view_entry.php (opens in a new tab)
- github.com/meeting-room-booking-system/mrbs-code/releases/tag/v1.12.3 (opens in a new tab)
- vulncheck.com/advisories/mrbs-before-1.12.3-reflected-xss-via-error-parameter-of-view-entry-php (opens in a new tab)