SunEditor before 3.4.0 contains a stored cross-site scripting vulnerability because the html.clean() sanitizer's
Source GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.4.0 as a priority.
Data as of 8 Nov 2026, 17:50 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|
- Patch
- Available – fixed in 3.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade suneditor to 3.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JiHong88suneditor | Affected
| Fixed in
|
npmsuneditorpkg:npm/suneditorOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in SunEditor version 3.4.0 and later. Users should upgrade to version 3.4.0 or above to remediate this vulnerability. No other mitigation or temporary workaround is indicated in the available data.
Description
SunEditor versions before 3.4.0 have a stored cross-site scripting (XSS) vulnerability. This occurs because the html.clean() sanitizer's _normalizeURL() function improperly decodes named entities like : to an empty string. As a result, attackers can inject href attributes with values such as javascript: that bypass the _isSafeURL() check but are decoded by browsers, leading to JavaScript execution when users click the stored links.