Skip to main content
CVE-2026-124493VulnerabilityPublished

SunEditor before 3.4.0 contains a stored cross-site scripting vulnerability in the DocumentType constructor that

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-124493· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.4.0 as a priority.

Data as of 8 Nov 2026, 17:50 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.3
Patch
Available – fixed in 3.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade suneditor to 3.4.0.

Affected software

ProductAffectedFixed in
JiHong88suneditorAffected
  • <3.4.0
Fixed in
  • 3.4.0
npmsuneditorpkg:npm/suneditorOther threatsAffected
  • <3.4.0
Fixed in
  • 3.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in SunEditor version 3.4.0 and later. Users should upgrade to version 3.4.0 or newer to remediate this vulnerability. No additional vendor advisory or patch links are provided, but upgrading to the fixed version is the recommended action.

Description

SunEditor versions prior to 3.4.0 have a stored cross-site scripting (XSS) vulnerability in the DocumentType constructor. This flaw occurs because header textContent is injected into innerHTML without proper HTML escaping. Attackers can exploit this by storing entity-encoded HTML in h1-h6 headers, which executes JavaScript when editors using document:header mode initialize, potentially leading to session cookie theft.

References

Community reviews

Loading reviews…