Skip to main content
CVE-2026-119054VulnerabilityPublished

Multiple Pages Generator by Themeisle before 4.2.5 contains a stored cross-site scripting vulnerability that allows

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119054· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade to 4.2.5 when convenient.

Data as of 29 Oct 2026, 16:51 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.1
CNA (VulnCheck)CVSS 3.15.4
Patch
Available – fixed in 4.2.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Multiple Pages Generator by Themeisle to 4.2.5.

Affected software

ProductAffectedFixed in
ThemeisleMultiple Pages Generator by ThemeisleAffected
  • <4.2.5
Fixed in
  • 4.2.5

AI-suggested

A fix is available in version 4.2.5 or later of the Multiple Pages Generator plugin by Themeisle. Users should upgrade to version 4.2.5 or newer to remediate this vulnerability. No alternative mitigations or temporary fixes are indicated in the provided data.

Description

Multiple Pages Generator by Themeisle versions before 4.2.5 contain a stored cross-site scripting (XSS) vulnerability. This flaw allows users with Contributor-level permissions to inject malicious scripts via the [mpg] and [mpg_match] shortcode base-url attribute. The vulnerability arises because entity-encoded payloads bypass kses filtering but are decoded and rendered unescaped in administrator browsers, enabling script execution.

References

Community reviews

Loading reviews…