Skip to main content
CVE-2026-119408VulnerabilityPublished

n8n before 2.42.6, 2.43.x before 2.43.3, and 3.x before 3.0.1 contains a remote code execution vulnerability via

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119408· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 2.43.3 soon.

Data as of 30 Oct 2026, 13:47 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
CNACVSS 4.08.7
Patch
Available – fixed in 2.43.3, 2.42.6, 3.0.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=2.43.0 <2.43.3
Fixed in
  • 2.43.3
n8n-ion8nAffected
  • <2.42.6
Fixed in
  • 2.42.6
n8n-ion8nAffected
  • >=3.0.0 <3.0.1
Fixed in
  • 3.0.1
npmn8npkg:npm/n8nOther threatsAffected
  • >=2.43.0 <2.43.3
  • <2.42.6
  • >=3.0.0 <3.0.1
Fixed in
  • 2.43.3
  • 2.42.6
  • 3.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade n8n to versions 2.42.6 or later for the 2.42 branch, 2.43.3 or later for the 2.43 branch, and 3.0.1 or later for the 3.x branch to remediate this vulnerability.

Description

A remote code execution vulnerability exists in n8n versions before 2.42.6, 2.43.x before 2.43.3, and 3.x before 3.0.1. This flaw involves deprecated Function, Function Item, and LangChain Code nodes that run outside the task runner isolation, allowing authenticated users with workflow creation or modification privileges to execute arbitrary JavaScript code in the main n8n process.

References

Community reviews

Loading reviews…