CVE-2024-14001: Nagios XI versions prior to 2024R1.1.3 are vulnerable to cross-site scripting (XSS) via the Executive
Source GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2024R1.1.3 when convenient.
Data as of 4 Nov 2026, 18:31 UTC
- Patch
- Available – fixed in 2024R1.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade XI to 2024R1.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NagiosXI | Affected
| Fixed in
|
AI-suggested
Until an official fix is confirmed, users should exercise caution with untrusted input in the Executive Summary Report component and consider restricting access to trusted users only.
Description
Nagios XI versions prior to 2024R1.1.3 contain a cross-site scripting (XSS) vulnerability in the Executive Summary Report component. This flaw arises from insufficient validation or escaping of user-supplied input, allowing attackers to inject and execute arbitrary scripts in the context of a victim's browser. The vulnerability has a medium severity rating with a CVSS score of 5.4.