Netty netty-tcnative before 2.0.84.Final contains a heap buffer overflow vulnerability in the tcn_write_to_bytebuffer
Affects netty-tcnativeSource GCVE Database
Not known to be exploited · CVSS 8.2 High · fixed in 2.0.84 : patch netty-tcnative soon.
Data as of 28 Oct 2026, 22:42 UTC
- Patch
- Available – fixed in 2.0.84
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10netty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in netty-tcnative version 2.0.84.Final. Users should upgrade to this version or later to remediate the vulnerability. No other mitigation or workaround is indicated by the vendor advisory or referenced sources.
Description
Netty netty-tcnative versions before 2.0.84.Final have a heap buffer overflow vulnerability in the tcn_write_to_bytebuffer BIO callback. This flaw arises from improper handling of the non-application ring buffer write index, allowing remote TLS peers to trigger an out-of-bounds memory copy. Exploitation can cause the JVM process to crash during handshake, renegotiation, or post-handshake message processing.
References
- ubuntu.com/security/CVE-2026-116539 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-116539 (opens in a new tab)
- github.com/netty/netty-tcnative (opens in a new tab)
- repo1.maven.org/maven2/io/netty/netty-tcnative (opens in a new tab)
- repo1.maven.org/maven2/io/netty/netty-tcnative-boringssl-static (opens in a new tab)
- github.com/cveproject/cvelistv5/tree/main/cves/2026/116xxx/cve-2026-116539.json (opens in a new tab)
- github.com/netty/netty-tcnative/blob/netty-tcnative-parent-2.0.83.final/openssl-dynamic/src/main/c/ssl.c (opens in a new tab)
- github.com/netty/netty-tcnative/commit/92dd66fd1243d85c05a61288f96367a70260b6b8 (opens in a new tab)
- github.com/netty/netty-tcnative/releases/tag/netty-tcnative-parent-2.0.84.final (opens in a new tab)
- github.com/netty/netty-tcnative/security/advisories/ghsa-gf9q-9mg7-g5qh (opens in a new tab)
- nvd.nist.gov/vuln/detail/cve-2026-116539 (opens in a new tab)
- security-tracker.debian.org/tracker/cve-2026-116539 (opens in a new tab)
- vulncheck.com/advisories/netty-netty-tcnative-before-2.0.84-final-heap-buffer-overflow-via-openssl-bio (opens in a new tab)