Skip to main content
CVE-2026-116542VulnerabilityPublished Updated

Netty netty-tcnative before 2.0.84.Final contains an SNI hostname spoofing vulnerability that allows remote

Affects netty-tcnativeSource GCVE Database

0
Authoritative record:CVE-2026-116542· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium · fixed in 2.0.84 : update netty-tcnative when convenient.

Data as of 28 Oct 2026, 22:42 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.84
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10netty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=stonkingOther threatsAffected
  • =2.0.28-1build5
  • =2.0.28-1build6
Fixed in–
Ubuntu 26.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=resoluteOther threatsAffected
  • =2.0.28-1build4
  • =2.0.28-1build5
Fixed in–
Ubuntu 24.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=nobleOther threatsAffected
  • 2.0.28-1build1 – 2.0.28-1build4
4 affected builds
Fixed in–
Ubuntu 22.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=jammyOther threatsAffected
  • =2.0.28-1
  • =2.0.28-1build1
Fixed in–
Ubuntu 20.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=focalOther threatsAffected
  • =2.0.20-1
  • =2.0.28-1
Fixed in–
Ubuntu 18.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=bionicOther threatsAffected
  • =1.1.33.Fork26-1
  • =1.1.33.Fork26-1build1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in netty-tcnative version 2.0.84.Final. Users should upgrade to this version or later to remediate the vulnerability. There are no indications that the vulnerability is mitigated by configuration or that no action is required.

Description

Netty netty-tcnative versions before 2.0.84.Final contain a Server Name Indication (SNI) hostname spoofing vulnerability. This flaw allows remote unauthenticated clients to manipulate hostnames via JNI NewStringUTF decoding by sending overlong encodings in the ClientHello server_name field. The vulnerability can cause confusion in SNI-based certificate selection, access control decisions, and logging, potentially leading to incorrect hostname handling.

References

Community reviews

Loading reviews…