Skip to main content
CVE-2026-116540VulnerabilityPublished Updated

netty-tcnative 2.0.66.Final before 2.0.84.Final built against OpenSSL 3.x contains a use-after-free vulnerability in

Affects netty-tcnativeSource GCVE Database

0
Authoritative record:CVE-2026-116540· High 8.2

Not known to be exploited · CVSS 8.2 High : patch netty-tcnative soon.

Data as of 28 Oct 2026, 22:42 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10netty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=stonkingOther threatsAffected
  • =2.0.28-1build5
  • =2.0.28-1build6
Fixed in–
Ubuntu 26.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=resoluteOther threatsAffected
  • =2.0.28-1build4
  • =2.0.28-1build5
Fixed in–
Ubuntu 24.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=nobleOther threatsAffected
  • 2.0.28-1build1 – 2.0.28-1build4
4 affected builds
Fixed in–
Ubuntu 22.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=jammyOther threatsAffected
  • =2.0.28-1
  • =2.0.28-1build1
Fixed in–
Ubuntu 20.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=focalOther threatsAffected
  • =2.0.20-1
  • =2.0.28-1
Fixed in–
Ubuntu 18.04 LTSnetty-tcnativepkg:deb/ubuntu/netty-tcnative?arch=source&distro=bionicOther threatsAffected
  • =1.1.33.Fork26-1
  • =1.1.33.Fork26-1build1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade netty-tcnative to version 2.0.84.Final or later, where this vulnerability is fixed. Refer to the official Debian security tracker advisory for patch details. No other mitigations are indicated.

Description

A use-after-free vulnerability exists in netty-tcnative versions before 2.0.84.Final when built against OpenSSL 3.x. The flaw occurs during TLS session ticket key rotation, where remote clients performing TLS handshakes can trigger OpenSSL to read freed HMAC keys, potentially causing crashes or corruption in ticket processing.

References

Community reviews

Loading reviews…