Skip to main content
VulnerabilityPublished

CVE-2026-15176: nginx vulnerabilities

Affects nginxSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-15176· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in 1.18.0-6ubuntu14.22 : patch nginx soon.

Data as of 26 Oct 2026, 23:00 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.18.0-6ubuntu14.22, 1.24.0-2ubuntu7.19, 1.30.4-7ubuntu1.1 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10nginxpkg:deb/ubuntu/nginx?arch=source&distro=stonkingOther threatsAffected
  • <1.30.4-7ubuntu1.1
Fixed in
  • 1.30.4-7ubuntu1.1
Ubuntu 26.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=resoluteOther threatsAffected
  • <1.28.3-2ubuntu1.12
Fixed in
  • 1.28.3-2ubuntu1.12
Ubuntu 24.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=nobleOther threatsAffected
  • <1.24.0-2ubuntu7.19
Fixed in
  • 1.24.0-2ubuntu7.19
Ubuntu 22.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=jammyOther threatsAffected
  • <1.18.0-6ubuntu14.22
Fixed in
  • 1.18.0-6ubuntu14.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and can be applied by updating nginx packages to the versions listed in the Ubuntu security notice USN-8955-1. Users should perform a standard system update to obtain these patched versions. No additional mitigation actions are specified beyond applying the official updates.

Description

Multiple vulnerabilities were discovered in nginx affecting various configurations and features, including alias directive with rewrite rules, map directives with regex matching, HTTP/3 request handling with proxy_request_buffering enabled, asynchronous file I/O with Server Side Includes, and SSL session ticket key handling with shared session cache. These issues could allow remote attackers to cause denial of service via crashes, execute arbitrary code, inject data into proxied requests, or forge client SSL sessions to bypass client certificate verification. The vulnerabilities affect specific Ubuntu package versions and have been addressed in updated package releases.

References

Community reviews

Loading reviews…