Skip to main content
VulnerabilityPublished Updated

CVE-2026-45623: Node postcss · PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree

Affects node-postcssSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.1 Critical · fixed in 8.5.12 : patch node-postcss as a priority.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10node-postcsspkg:deb/ubuntu/node-postcss?arch=source&distro=stonkingOther threatsAffected
  • 8.5.8+~cs9.3.30-1 – 8.5.26+~cs10.2.24-1
6 affected builds
Fixed in–
Ubuntu 26.04 LTSnode-postcsspkg:deb/ubuntu/node-postcss?arch=source&distro=resoluteOther threatsAffected
  • =8.5.6+~cs9.3.28-1
  • =8.5.8+~cs9.3.30-1
Fixed in–
Ubuntu 24.04 LTSnode-postcsspkg:deb/ubuntu/node-postcss?arch=source&distro=nobleOther threatsAffected
  • =8.4.20+~cs8.0.23-1
  • =8.4.31+~cs8.0.26-1
Fixed in–
Ubuntu 22.04 LTSnode-postcsspkg:deb/ubuntu/node-postcss?arch=source&distro=jammyOther threatsAffected
  • =8.2.1+~cs5.3.23-8
  • =8.4.5+~cs7.1.51-2
  • =8.4.6+~cs7.3.21-1
Fixed in–
Ubuntu 20.04 LTSnode-postcsspkg:deb/ubuntu/node-postcss?arch=source&distro=focalOther threatsAffected
  • =6.0.23-1
  • =6.0.23-3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in node-postcss version 8.5.12. Users should update to this version or later to remediate the vulnerability. Red Hat Satellite users should follow the Red Hat advisory RHSA-2026:74621 and update their systems accordingly.

Description

A vulnerability in node-postcss versions 8.5.11 and earlier allows attackers controlling CSS input to cause the host process to read arbitrary local files due to improper validation of sourceMappingURL comments. This can leak file contents via JSON.parse error messages and be used as a file-existence oracle or cause denial of service. The issue is fixed in version 8.5.12. Red Hat Satellite users are advised to update accordingly.

References

Community reviews

Loading reviews…