Skip to main content
VulnerabilityPublished Updated

CVE-2026-53815: OpenClaw · Message read actions could skip channel allowlist checks

Affects openclaw-cliSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2026.5.19 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.5.19
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade openclaw and openclaw-cli to 2026.5.19.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.19
Fixed in
  • 2026.5.19
Homebrewopenclaw-clipkg:brew/openclaw-cliOther threatsAffected
  • >=2026.1.29 <2026.5.19
Fixed in
  • 2026.5.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in OpenClaw CLI version 2026.5.19; upgrading to this version or later resolves the issue. Until patched, restrict message read actions to trusted operators and maintain narrow channel allowlists. Additionally, avoid sharing a Gateway instance among mutually untrusted users and disable the affected feature if it is not required.

Description

OpenClaw CLI versions before 2026.5.19 contain a vulnerability where message read actions can bypass channel allowlist checks. This allows lower-trust callers with access to these actions to request messages from channels they should not normally access. The impact depends on the operator's configuration and whether untrusted inputs can reach the vulnerable path. The issue does not affect the trusted-operator model but can expose sensitive messages if the feature is enabled and reachable. A fix is available in version 2026.5.19.

References

Community reviews

Loading reviews…