Skip to main content
VulnerabilityPublished Updated

CVE-2026-53816: OpenClaw · Paired nodes could forge exec lifecycle events without system.run provenance

Affects openclaw-cliSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 2026.5.18 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.5.18
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade openclaw and openclaw-cli to 2026.5.18.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.18
Fixed in
  • 2026.5.18
Homebrewopenclaw-clipkg:brew/openclaw-cliOther threatsAffected
  • >=2026.1.29 <2026.5.18
Fixed in
  • 2026.5.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenClaw CLI to version 2026.5.18 or later, where this vulnerability is patched. Additionally, pair nodes only from trusted environments and remove or re-pair any nodes that may have been compromised to prevent exploitation.

Description

OpenClaw CLI versions prior to 2026.5.18 contain a vulnerability where paired nodes can forge exec lifecycle events without sufficient provenance verification. This allows a malicious or compromised paired node to send crafted lifecycle events to the gateway, potentially causing the gateway to treat attacker-supplied data as legitimate exec lifecycle results. The vulnerability requires the attacker to already control a paired node connection and does not allow unauthenticated access to the gateway. The issue is resolved in version 2026.5.18.

References

Community reviews

Loading reviews…