CVE-2026-53810: Openclaw cli · OpenClaw's marketplace runtime extension metadata could point at unscanned payloads
Affects openclaw-cliSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2026.5.18 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.5.18
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openclaw and openclaw-cli to 2026.5.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmopenclaw | Affected
| Fixed in
|
Homebrewopenclaw-clipkg:brew/openclaw-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in OpenClaw CLI version 2026.5.18. Until patched, operators should install only trusted plugins and maintain explicit plugin allowlists. Additional hardening includes keeping channel and tool allowlists narrow, avoiding sharing a Gateway between mutually untrusted users, and disabling the affected feature when not needed.
Description
OpenClaw CLI versions prior to 2026.5.18 contain a vulnerability where marketplace runtime extension metadata can redirect runtime loading to unscanned payloads. This allows a package selected by a trusted operator to load plugin code outside the reviewed package entry points. The vulnerability depends on the operator's configuration and whether lower-trust input can reach the affected feature. A fix is available in version 2026.5.18.
References
- github.com/openclaw/openclaw/security/advisories/GHSA-v6r2-jh58-xx6w (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53810 (opens in a new tab)
- github.com/openclaw/openclaw (opens in a new tab)
- vulncheck.com/advisories/openclaw-arbitrary-code-execution-via-unscanned-marketplace-runtime-extension-metadata (opens in a new tab)