Skip to main content
VulnerabilityPublished

OpenClaw's Gateway Control UI bootstrap config required Gateway auth

Affects openclawSource GCVE Database

0

CVSS 6.9 Medium : upgrade to 2026.4.22 when convenient.

Data as of 27 Oct 2026, 01:26 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.4.22
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

What to do

Upgrade openclaw to 2026.4.22.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.4.22
Fixed in
  • 2026.4.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenClaw version 2026.4.22, which enforces Gateway authentication on the bootstrap config endpoint. Users should upgrade to this version to remediate the vulnerability. No additional mitigation steps are required as the patch fully addresses the issue.

Description

OpenClaw's Gateway Control UI bootstrap configuration endpoint was accessible without proper Gateway authentication in versions up to 2026.4.21. This could expose sensitive bootstrap and configuration fields intended only for authenticated sessions. The issue was fixed in version 2026.4.22 by enforcing the same Gateway read-authentication on the bootstrap config route as other Control UI reads.

References

Community reviews

Loading reviews…