Skip to main content
VulnerabilityPublished

CVE-2026-106587: openssh security update

Affects opensshSource GCVE Database

0
Compare
Authoritative record:CVE-2026-106587· Low 3.6

Not known to be exploited · CVSS 3.6 Low : upgrade to 9.6p1-25.oe2403sp3 when convenient.

Data as of 4 Nov 2026, 16:59 UTC

CVSS 3.1 base score
3.6Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.6p1-25.oe2403sp3
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade openssh to 9.6p1-25.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3opensshpkg:rpm/openEuler/openssh&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <9.6p1-25.oe2403sp3
Fixed in
  • 9.6p1-25.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in OpenSSH version 9.6p1-25.oe2403sp3. Users should upgrade to this version or later to remediate the vulnerability.

Description

OpenSSH versions before 9.6p1-25.oe2403sp3 contain a vulnerability where the configuration option value "none" is sometimes incorrectly interpreted as a filename instead of disabling a feature. This issue was fixed in version 9.6p1-25.oe2403sp3.

References

Community reviews

Loading reviews…