Skip to main content
CVE-2024-5594VulnerabilityPublished Updated

OpenVPN before 2.6.11 does not santize PUSH_REPLY messages properly which attackers can use to inject unexpected

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-5594· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 2.6.11 : patch affected systems as a priority.

Data as of 30 Oct 2026, 00:55 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.1
Patch
Available – fixed in 2.6.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

Upgrade OpenVPN to version 2.6.11 or later, where this vulnerability has been addressed. No alternative mitigations are specified.

Description

OpenVPN versions prior to 2.6.11 have a vulnerability where PUSH_REPLY messages are not properly sanitized. This flaw allows attackers to inject arbitrary data into third-party executables or plug-ins, potentially leading to unauthorized code execution or manipulation.

References

Community reviews

Loading reviews…