CVE-2026-111959: Apache Arrow Rust (arrow crate) · Out-of-bounds Read Vulnerability
Source GCVE Database
Not known to be exploited : upgrade to 60.1.0 soon.
Data as of 2 Nov 2026, 16:59 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 60.1.0
Exploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Apache Arrow Rust and arrow to 60.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Arrow Rustarrow | Affected
| Fixed in
|
crates.ioarrowpkg:cargo/arrowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to the fixed versions 57.3.2, 58.4.1, 59.3.2, or 60.1.0 of the Apache Arrow Rust 'arrow' crate to remediate this vulnerability. No other mitigation steps are indicated by the vendor advisory.
Description
An out-of-bounds read vulnerability exists in the Apache Arrow Rust 'arrow' crate affecting versions from 33.0.0 through 57.3.1, 58.4.0, 59.3.1, and 60.0.0. The flaw arises from improper validation of RunEndEncoded arrays in the ArrayData interface, which can lead to reading data beyond the bounds of the child values array. This issue is fixed in versions 57.3.2, 58.4.1, 59.3.2, and 60.1.0.