Skip to main content
CVE-2026-111732VulnerabilityPublished

P-Net before 1.0.3, when built with PNET_OPTION_AR_VENDOR_BLOCKS enabled, parses a data length from a field of the

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-111732· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.0.3 as a priority.

Data as of 29 Oct 2026, 19:59 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (rt-labs)CVSS 4.09.3
Patch
Available – fixed in 1.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade P-Net to 1.0.3.

Affected software

ProductAffectedFixed in
RT-LabsP-NetAffected
  • <1.0.3
Fixed in
  • 1.0.3

AI-suggested

Upgrade to P-Net version 1.0.3 or later where this vulnerability is fixed. If upgrading is not immediately possible, ensure that the PNET_OPTION_AR_VENDOR_BLOCKS option remains disabled, as it is by default, to avoid exposure. There is no indication of any other mitigation or temporary fix. Monitor vendor advisories for official patches or updates.

Description

P-Net versions before 1.0.3, when compiled with the PNET_OPTION_AR_VENDOR_BLOCKS option enabled, contain a vulnerability where a data length is parsed from a field in the ARVendorBlock request that is not part of the block definition. This length is used to copy bytes into a fixed-size buffer without proper bounds checking, leading to an out-of-bounds write. This flaw can cause a crash resulting in denial of service or potentially allow arbitrary code execution. The vulnerable option is disabled by default.

References

Community reviews

Loading reviews…